Fetch a List of Software Installed on an Image

Shows the software installed on an image.

GET/v1.3/images/{imageSha}/software

Input ParametersInput Parameters

Parameter

Mandatory/Optional

Data Type

Description

imageSha

Mandatory

string

Specify the SHA value of a specific image in the user’s scope.

filter

Optional

string

Filter the images list by providing a query using Qualys syntax.

Refer to the “How to Search” topic in the online help for assistance with creating your query.

sort

Optional

string

Sort the results using a Qualys token. For example qid:asc.

Refer to the “Sortable tokens” topic in the online help for more information.

SampleSample

API request

    curl -X GET
"<qualys_base_url>/csapi/v1.3/images/fddd5d9814a9393cf85f4794c6435ba00e8db8facee9bcc05d9d0846016470df/software"
-H "accept: application/json"
-H "Authorization: Bearer <token>"

Response

    	{
  "data": [
    {
      "name": "libsystemd0:amd64",
      "version": "237-3ubuntu10.33",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "237-3ubuntu10.54",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "diffutils",
      "version": "1:3.6-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libhogweed4:amd64",
      "version": "3.4-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "3.4.1-0ubuntu0.18.04.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "libprocps6:amd64",
      "version": "2:3.3.12-3ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libonig4:amd64",
      "version": "6.7.0-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libseccomp2:amd64",
      "version": "2.4.1-0ubuntu0.18.04.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mongodb-org-mongos",
      "version": "4.2.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "pinentry-curses",
      "version": "1.1.0-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "adduser",
      "version": "3.116ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libheimbase1-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "gpgconf",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "procps",
      "version": "2:3.3.12-3ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "passwd",
      "version": "1:4.5-1ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1:4.5-1ubuntu2.2",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libgmp10:amd64",
      "version": "2:6.1.2+dfsg-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2:6.1.2+dfsg-2ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "publicsuffix",
      "version": "20180223.1310-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "apt",
      "version": "1.6.12",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.6.12ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libaudit-common",
      "version": "1:2.8.2-1ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "ncurses-base",
      "version": "6.1-1ubuntu1.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gnupg",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libgssapi-krb5-2:amd64",
      "version": "1.16-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.16-2ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "mongodb-org",
      "version": "4.2.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libcom-err2:amd64",
      "version": "1.44.1-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.44.1-1ubuntu1.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "base-passwd",
      "version": "3.5.44",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "lsb-base",
      "version": "9.20170808ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gpg-wks-server",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "krb5-locales",
      "version": "1.16-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.16-2ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libk5crypto3:amd64",
      "version": "1.16-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.16-2ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libncurses5:amd64",
      "version": "6.1-1ubuntu1.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libpam-modules-bin",
      "version": "1.1.8-3.6ubuntu2.18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libp11-kit0:amd64",
      "version": "0.23.9-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "0.23.9-2ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "sensible-utils",
      "version": "0.0.12",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "ca-certificates",
      "version": "20180409",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "20210119~18.04.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "libkrb5-3:amd64",
      "version": "1.16-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.16-2ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "dash",
      "version": "0.5.8-2.10",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "findutils",
      "version": "4.6.0+git+20170828-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mawk",
      "version": "1.3.3-17ubuntu3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libunistring2:amd64",
      "version": "0.9.9-0ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libuuid1:amd64",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libsemanage-common",
      "version": "2.7-2build2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "ncurses-bin",
      "version": "6.1-1ubuntu1.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libaudit1:amd64",
      "version": "1:2.8.2-1ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libpcre3:amd64",
      "version": "2:8.39-9",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2:8.39-9ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libselinux1:amd64",
      "version": "2.7-2build2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libnpth0:amd64",
      "version": "1.5-3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mongodb-org-tools",
      "version": "4.2.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libsqlite3-0:amd64",
      "version": "3.22.0-1ubuntu0.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "3.22.0-1ubuntu0.6",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 1,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "readline-common",
      "version": "7.0-3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libhx509-5-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libtinfo5:amd64",
      "version": "6.1-1ubuntu1.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "grep",
      "version": "3.1-2build1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gpgsm",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libblkid1:amd64",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libgcrypt20:amd64",
      "version": "1.8.1-4ubuntu1.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.8.1-4ubuntu1.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libldap-common",
      "version": "2.4.45+dfsg-1ubuntu1.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.4.45+dfsg-1ubuntu1.11",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 5,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libncursesw5:amd64",
      "version": "6.1-1ubuntu1.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gnupg-l10n",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libdebconfclient0:amd64",
      "version": "0.213ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gpgv",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libc6:amd64",
      "version": "2.27-3ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.27-3ubuntu1.5",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libkeyutils1:amd64",
      "version": "1.5.9-9.2ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "debianutils",
      "version": "4.8.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libjq1:amd64",
      "version": "1.5+dfsg-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "bash",
      "version": "4.4.18-2ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "4.4.18-2ubuntu1.3",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libpam0g:amd64",
      "version": "1.1.8-3.6ubuntu2.18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libcap-ng0:amd64",
      "version": "0.7.7-3.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libksba8:amd64",
      "version": "1.3.5-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.3.5-2ubuntu0.18.04.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libnghttp2-14:amd64",
      "version": "1.30.0-1ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libbz2-1.0:amd64",
      "version": "1.0.6-8.1ubuntu0.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libheimntlm0-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libudev1:amd64",
      "version": "237-3ubuntu10.33",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "237-3ubuntu10.54",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "libsemanage1:amd64",
      "version": "2.7-2build2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libgcc1:amd64",
      "version": "1:8.3.0-6ubuntu1~18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "zlib1g:amd64",
      "version": "1:1.2.11.dfsg-0ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1:1.2.11.dfsg-0ubuntu2.2",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libdb5.3:amd64",
      "version": "5.3.28-13.1ubuntu1.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libapt-pkg5.0:amd64",
      "version": "1.6.12",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.6.12ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libgpg-error0:amd64",
      "version": "1.27-6",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libstdc++6:amd64",
      "version": "8.3.0-6ubuntu1~18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libwind0-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libkrb5-26-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "coreutils",
      "version": "8.28-1ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libasn1-8-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libroken18-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libext2fs2:amd64",
      "version": "1.44.1-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.44.1-1ubuntu1.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "gpg",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libsasl2-modules-db:amd64",
      "version": "2.1.27~101-g0780600+dfsg-3ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.1.27~101-g0780600+dfsg-3ubuntu2.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libgssapi3-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libtasn1-6:amd64",
      "version": "4.13-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mongodb-org-shell",
      "version": "4.2.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "ubuntu-keyring",
      "version": "2018.09.18.1~18.04.0",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libldap-2.4-2:amd64",
      "version": "2.4.45+dfsg-1ubuntu1.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.4.45+dfsg-1ubuntu1.11",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 5,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libffi6:amd64",
      "version": "3.2.1-8",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libpsl5:amd64",
      "version": "0.19.1-5build1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "jq",
      "version": "1.5+dfsg-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "sysvinit-utils",
      "version": "2.88dsf-59.10ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libgnutls30:amd64",
      "version": "3.5.18-1ubuntu1.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "3.5.18-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "librtmp1:amd64",
      "version": "2.4+20151223.gitfa8646d.1-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gzip",
      "version": "1.6-5ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.6-5ubuntu1.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "tar",
      "version": "1.29b-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.29b-2ubuntu0.3",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "dirmngr",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "gcc-8-base:amd64",
      "version": "8.3.0-6ubuntu1~18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mongodb-org-server",
      "version": "4.2.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "gnupg-utils",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libsepol1:amd64",
      "version": "2.7-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.7-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 0,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "openssl",
      "version": "1.1.1-1ubuntu2.1~18.04.5",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.1.1-1ubuntu2.1~18.04.20",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 4,
        "severity3Count": 5,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "init-system-helpers",
      "version": "1.51",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libkrb5support0:amd64",
      "version": "1.16-2ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.16-2ubuntu0.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "gpg-agent",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libssl1.1:amd64",
      "version": "1.1.1-1ubuntu2.1~18.04.5",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.1.1-1ubuntu2.1~18.04.20",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 4,
        "severity3Count": 5,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libfdisk1:amd64",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "debconf",
      "version": "1.5.66ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libnettle6:amd64",
      "version": "3.4-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "3.4.1-0ubuntu0.18.04.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "libidn2-0:amd64",
      "version": "2.0.4-1.1ubuntu0.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libhcrypto4-heimdal:amd64",
      "version": "7.5.0+dfsg-1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.5.0+dfsg-1ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libss2:amd64",
      "version": "1.44.1-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.44.1-1ubuntu1.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "liblzma5:amd64",
      "version": "5.2.2-1.3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "5.2.2-1.3ubuntu0.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libc-bin",
      "version": "2.27-3ubuntu1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.27-3ubuntu1.5",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "hostname",
      "version": "3.20",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libassuan0:amd64",
      "version": "2.5.1-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "util-linux",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "perl-base",
      "version": "5.26.1-6ubuntu0.3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "5.26.1-6ubuntu0.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "tzdata",
      "version": "2019c-0ubuntu0.18.04",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "login",
      "version": "1:4.5-1ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1:4.5-1ubuntu2.2",
      "vulnerabilities": {
        "severity5Count": 1,
        "severity4Count": 0,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "bsdutils",
      "version": "1:2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libattr1:amd64",
      "version": "1:2.4.47-2build1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "mount",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libreadline7:amd64",
      "version": "7.0-3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "e2fsprogs",
      "version": "1.44.1-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.44.1-1ubuntu1.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libpam-modules:amd64",
      "version": "1.1.8-3.6ubuntu2.18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libcurl4:amd64",
      "version": "7.58.0-2ubuntu3.8",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "7.58.0-2ubuntu3.20",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 4,
        "severity3Count": 6,
        "severity2Count": 1,
        "severity1Count": 0
      }
    },
    {
      "name": "gpg-wks-client",
      "version": "2.2.4-1ubuntu1.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.2.4-1ubuntu1.6",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 2,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "sed",
      "version": "4.4-2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libnuma1:amd64",
      "version": "2.0.11-2.1ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libmount1:amd64",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "fdisk",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libsmartcols1:amd64",
      "version": "2.31.1-0.4ubuntu3.4",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "dpkg",
      "version": "1.19.0.5ubuntu2.3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.19.0.5ubuntu2.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 1,
        "severity3Count": 0,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "bzip2",
      "version": "1.0.6-8.1ubuntu0.2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "base-files",
      "version": "10.1ubuntu2.7",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libacl1:amd64",
      "version": "2.2.52-3build1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "liblz4-1:amd64",
      "version": "0.0~r131-2ubuntu3",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "0.0~r131-2ubuntu3.1",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "libzstd1:amd64",
      "version": "1.3.3+dfsg-2ubuntu1.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "1.3.3+dfsg-2ubuntu1.2",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 1,
        "severity2Count": 0,
        "severity1Count": 0
      }
    },
    {
      "name": "numactl",
      "version": "2.0.11-2.1ubuntu0.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libpam-runtime",
      "version": "1.1.8-3.6ubuntu2.18.04.1",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": null,
      "vulnerabilities": {
        "severity5Count": null,
        "severity4Count": null,
        "severity3Count": null,
        "severity2Count": null,
        "severity1Count": null
      }
    },
    {
      "name": "libsasl2-2:amd64",
      "version": "2.1.27~101-g0780600+dfsg-3ubuntu2",
      "scanType": "DYNAMIC",
      "packagePath": null,
      "fixVersion": "2.1.27~101-g0780600+dfsg-3ubuntu2.4",
      "vulnerabilities": {
        "severity5Count": 0,
        "severity4Count": 0,
        "severity3Count": 2,
        "severity2Count": 0,
        "severity1Count": 0
      }
    }
  ],
  "count": 144,
  "softwareCountBySeverity": {
    "severity5Count": 8,
    "severity3Count": 43,
    "severity4Count": 40,
    "severity1Count": 0,
    "severity2Count": 7
  },
  "driftSoftwareCountBySeverity": null,
  "driftSoftwareCountByDriftReason": null
}

Sample with SCA ScanningSample with SCA Scanning

This is applicable for subscriptions with SCA Scanning enabled and for images scanned using SCA. You’ll see SCA for scanType when the software was detected by an SCA scan.

API request

    curl -X GET
"<qualys_base_url>/csapi/v1.3/images/5d556c82899c/software" --header "Authorization: Bearer <token>"
    

Response

    {
    "data": [
        {
            "name": "org.apache.maven.resolver:maven-resolver-transport-wagon",
            "version": "1.6.3",
            "scanType": "SCA",
            "packagePath": "usr/share/maven/lib/maven-resolver-transport-wagon-1.6.3.jar",
            "fixVersion": null,
            "vulnerabilities": {
                "severity5Count": null,
                "severity4Count": null,
                "severity3Count": null,
                "severity2Count": null,
                "severity1Count": null
            }
        },
   
   ...
}
    

 

 

Was this topic helpful?

success Thank you! We're glad to hear that this topic was useful.
success We appreciate your feedback. We'll work to make this topic better for you in the future.